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AMENDMENT HISTORY 

Version Date Description 

V2.9 May, 2017 

1. Add New IC writer function : 

TM52 series：TM52F5250, TM52F5264C, TM52F5268C,  

TM52F5273B, TM52F5274C, TM52F5276B,  

TM52F5278C,TM52F6264, TM52F6268. 

TM57series： TM57M5528, TM57M5538, TM57M5541,  

TM57M5545, TM57M5551, TM57MA17,  

TM57MA18, TM57MA21BZ, TM57MA28. 

TM87 series：TM87ML25L, TM87ML25H. 

2. Add Writer Simple Test/Reset Firmware/Read Hradware ID 

function. 

3. Upgrade 51 MCU series IC programming 

capability/stability/programming speed. 

4. Add Tx37 series IC license mode function. 

5. Modify some software/firmware bugs 

6. Writer user manual update 

V3.0 Jun, 2017 1. Writer user manual update 

V3.1 July, 2017 

1. Add New IC writer function : 

TM57 series：TM57ME15, TM57M5526C, TM57M5536C 

2. Modify some software/firmware bugs 

3. Writer user manual update 

V3.2 Feb, 2018 

1. Add New IC writer function : 

TM57series：TM57MA45, TM57MA46. 

2. TWR98 and TWR99 is combined to TWR100. 

3. Add IC Search function.  

4. Add the mouse can drag directly Download function.  

5. Software Help function add (Writer Simple Test/Reset 

Firmware/Read hradware ID function). 

6. Add Tx37 series IC Whole chip Erase function.  

7. Add Tx28 series rolling code function. 

8. Integration of the IC program information. 

9. Modify some software/firmware bugs. 

10. Writer user manual update. 
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PRODUCT NAME 

TWR98/99/100 

 

TITLE 

USB Writer 

 

FEATURES 

1. USB Interface. 

2. The device can be attached to a computer and controlled by software for programming or it can also 

be operated independently as a stand-alone writer. 

3. Both software and firmware can be updated. 

 

1. Supported IC Series 

1.1 Supported IC Type 

1. 4-bit TM87 series: TM8793, TM8795, TM87P04, TM87P08, TM87P18M, TM87ML25L(Note1), 

TM87ML25H(Note1) 

2. 4-bit TM89 series: TM89P51M, TM89P52M, TM89P55M, TM89P57M, TM89P59M 

3. 8-bit TM56 series: TM56MH40 

1. 8-bit TM57 series: TM57FA40, TM57FA40A, TM57FLA80, TM57FLA80A, TM57MA16,  

TM57MA1660, TM57MA1668, TM57MA1672, TM57MA20,TM57MA51A, 

TM57MA21B, TM57MA25, TM57ME20, TM57ME16, TM57ME16AS, 

TM57ML40, TM57MR10, TM57MR20, TM57PA10, TM57PA10A, 

TM57PA11, TM57PA11B , TM57PA15, TM57PA16, TM57PA16AS, 

TM57PA16B, TM57PA20, TM57PA20A, TM57PA20AS, TM57PA20B, 

TM57PA20E, TM57PA21, TM57PA21B, TM57PA25, TM57PA25B, 

TM57PA28, TM57PA40, TM57PA40E, TM57PA45, TM57PA45C, 

TM57PE10, TM57PE11, TM57PE11A,TM57PE11BS, TM57PE11C, 

TM57PE11CS, TM57PE12, TM57PE12D, TM57PE12AS, TM57PE15AS, 

TM57PE15A, TM57PE15C, TM57PE15CS, M57PE20A, TM57PE20B, 

TM57PE40, TM57PT16, TM57PT16AS, TM57PT16B, TM57PT20A, 

TM57PT20B, TM57PT45, TM57PT45C, TM57M5528, TM57M5538, 

TM57M5541, TM57M5545, TM57M5551, TM57MA17, TM57MA18, 

TM57MA21BZ, TM57MA28, TM57ME15, TM57M5526C, TM57M5536C, 

TM57MA45, TM57MA46 
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4. 51 MCU series:     TM52F2230, TM52F2234, TM52F2260, TM52F2261, TM52F2264, 

TM52F2280, TM52F2280B, TM52F2284, TM52F2284B, TM52M5254, 

TM52M5258,TM52F5264B, TM52F5268B,TM52F5274B, TM52F5278B, 

TM52F5284,TM52F5284C, TM52F5288, TM52F5288C, TM52F5250, 

TM52F5264C, TM52F5268C, TM52F5273B, TM52F5274C, TM52F5276B, 

TM52F5278C, TM52F5276, TM52F5273, TM52F2230B, TM52F2234B, 

TM52F2268 

5. USB series:         TMU3130, TMU3131, TMU3132, TMU3132LV, TMU32FA80 

 

Note1 : Only TWR100 hardware support 

 

1.2 Program Filename Extension: 

1. .epm file: TM87, TM89 series program filename 

2. .tenx file: 51 MCU series program filename 

3. .hex file: TM56, TM57 series program filename 
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2. Hardware and PC Setup 

2.1 System Requirements: 

a. Applicable in Windows 98/ME/2000/XP, Windows 7, Windows 8, Windows 8.1 system. 

b. Need more than 100MB of hard disk space. 

 
2.2 PC Setup: 

a. The user to enter tenx company website http://www.tenx.com.tw. 

b. Installation Setup_Writer_Version200_Build 001.exe 

 
2.3 Hardware connection: 

Step 1. Connect the DC 9V Adapter and USB Cable (mini B Type). 

 
 

Step 2. Turn the Power on. 

 
  

http://www.tenx.com.tw/
http://www/Files/Tools/68/82/Setup_Writer_Version1.0.0_Build%20006.exe
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3. Hardware Function Illustration 

a. TWR98  hardware (The following is a functional description) 

 
 

b. TWR99 hardware (The following is a functional description) 

 

 

3.3 

 

3.7 

3.2 3.1 

3.4 

3.3 

3.2 3.1 

3.7 

3.5 
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c. TWR100 hardware (The following is a functional description) 

 

 

 

 

 

 

 

 

 

3.3 

3.2 3.1 

3.7 

3.5 
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3.1 Mode function Key: Select the program mode function: 

a. Mode1: CHIP NAME 

 
 

b. Mode2: AUTO (Blank check + Program+Verify) function 

 
 

c. Mode3: BLANKCHECK function 

(OTP series IC: Blankcheck) 

(FLASH/MTP series IC: Erase+Blank check) 

 
 

d. Mode4: PROGRAM (Program+Verify) function 

 
 

e. Mode5: VERIFY function 
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f. Mode6: CHECKSUM_E =>Display the EEPROM buffer Checksum 

This function is used to check the correctness of the PC download data, which is to be 

programmed to the EEPROM. 

It is deemed correct if the Checksum value from EEPROM equals to the Checksum value 

from software. 

 
 

g. Mode7: CHECKSUM_O =>Display the OTP Chip Checksum 

This function is used to read back the data from the OTP Chip to do the Checksum 

calculation. 

It will be deemed correct only if the Checksum value from OTP chip equals to the 

Checksum value from EEPROM. 

 
 

h. Mode8: SW : =>Display Software version / FW : =>Display Firmware version 
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3.2 Enter function key: Execute the mode function 

 
3.3 LCD: Display the Mode function and programming result 

 
3.4 TWR98 Writer IC programming-pins 

 
 

3.4.1: TM87ML25L, TM87ML25H 

 
 

3.4.2: TM87P18M 

 
 

3.4.3: TM89P59, TM89P59M, TM89P55M, TM89P52M, TM89P57M 
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3.4.4: TM89P51M 

 
 

3.4.5: TM8793 

 
 

3.4.6: TM57PA10, TM57PA40, TM57PE11, TM57PA20, TM57PA21, TM57PE10,TM57PE11A,  

TM57PA10A, TM57PE12, TM57PE11B, TM57PE15A, TM57PE40,  

TM57PA21, TM57PA25, TM57PA20A, TM57P11, TM57P11B, TM57P11C, TM57PE11C,  

TM57PE15C, TM57P11CU, TM57PE12D, TM57PA11, TM57PE20A, TM57PT20A, 

TM57PA45, TM57PA15, TM57PA21B, TM57PA25B, TM57PA16, TM57PT16, TM57PT45, 

TM57MA25, TM57PA20B, TM57PA28, TM57PE20B, TM57PT20B, TM57PA16B, 

TM57PT16B, TM57PA45C, TM57PT45C 

 
 

3.4.7: TM57PE11B, TM57PE11C, TM57PE15AS, TM57PE15CS, TM57PE15AS, TM57PE12AS,  

TM57PA20AS 
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3.4.8: TM57FA40, TM57FA40A 

 
 

3.4.9: : TM57FLA80, TM57ME20, TM57MR10, TM57MR20, TM57MR10, TM57MA20, 

TM57MA21B, TM57MA16, TM57MA1660, TM57MA1668, TM57MA1672, TM57M5528, 

TM57M5538, TM57M5541, TM57M5545, TM57M5551, TM57MA17, TM57MA18, 

TM57MA21BZ, TM57MA28, TM57M5526C, TM57M5536C, TM57ME15, TM57ML40, 

TM57MA45, TM57MA46 

 

(1) non ISP mode 

 
 

(2) EXHV ISP mode  

 
 

3.4.10: TM57ME16, TM57ME16AS 
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3.4.11: TMU3130, TMU3132, TMU3132LV, TMU3115, TMU32FA80 

(1) non ISP mode 

 
 

(2) EXHV ISP mode 

 
 

3.4.12: TM52M5254, TM52M5258, TM52F5274B, TM52F5278B, TM52F5264B, TM52F5268B, 

TM52F5250, TM52F5264C, TM52F5268C, TM52F5273B, TM52F5274C, TM52F5276B, 

TM52F5278C, TM52F5276, TM52F5273 

 

(1) non ISP mode 

 
 

(2) EXHV ISP mode    (3) ISP mode 

  
Note : TM52M5254, TM52M5258 no support ISP mode 
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3.4.13: TM52F5284, TM52F5288, TM52F5284C, TM52F5288C 

(1) non ISP mode 

 
 

(2) EXHV ISP mode    (3) ISP mode 

  
 

3.4.14: TM52F2260, TM52F2261, TM52F2264 

(1) non ISP mode 

 
 

(2) EXHV ISP mode    (3) ISP mode 
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3.4.15: TM52F2280, TM52F2284, TM52F2230, TM52F2234, TM52F2230B, TM52F2234B, 

TM52F2280B, TM52F2284B, TM52F2268 

(1) non ISP mode 

 
 

(2) EXHV ISP mode    (3) ISP mode  
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3.5 Writer Socket 

 
3.6 EX_Control: External Control Signal 

 

 

3.5.1: Signal Name and location 

9: N.C. 7: Result2 5: GND 3: Result0 1: VDD 

10: N.C. 8: N.C. 6: GND 4: Result1 2: Start 

 

3.5.2: Signal Function 

1. VDD =>Output Power, +3V 

2. Start signal =>Input Start signal, Low Pulse valid (start signal valid wide>50 ms)  

3. Result0, Result1 and Result2 pins =>Output Programming result, the status is as below: 

Result2 Result1 Result0 Status 

1 0 0 BUSY 

0 1 0 FAIL 

0 0 1 OK 
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3.7 Semi-automatic Machine Control Signals 

3.7.1: Program ok signal 

 
 

3.7.2: Program Fail signal 

 
 

3.8 LED Description: 

3.8.1: Yellow LED: the LED blinks when downloading writer file data or during writing process, 

means it is in busy state. 

3.8.2: Red LED: red light ON means writing process fails. When IC is taken away or writing mode 

is switched to another mode, LED will be switched off.  

3.8.3: Green LED: green light ON means the writing process succeeded. When IC is taken away or 

writing mode is switched to another mode, LED will be switched off. 
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4. Software Function Guide 

 
 

1. Display the programming data 

2. Display whether the Writer Device is connected to PC or not 

3. Display OTP IC programming-pins placement (Corresponding to the Hardware programming 

port) 

4. Display the file path of program 

5. Display the name of the programming CHIP 

6. Display IC program mode 

7. Program Toolbar: 

7.1 Execute programming instruction (Auto, Blank, Check, Program, Verify etc… functions, 

which, just like using the hardware, can be executed directly from the software when the 

USB Writer Device is connected to the PC) 

7.2 Blank check function 

7.3 Program function (program+verify) 

7.4 Verify function 

8. Menu bar: 

8.1 File =>Load the programming file 

8.2 Device =>Select programming CHIP 

8.3 Operation =>Update firmware, Writer option set, Read IC information 

8.4 Help =>Writer Firmware Reset, Hareware Simple Test, Read Hardware ID 

8.5 About =>Display software version 

2 

1 
3 

4 5 
6 

7 

8 

9 

10 
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9. Checksum: Display the Checksum value of the programming file 

10. Smart Option: Display System Configuration definition 
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5. Programming Software Operation 

Step 1: Start the writer software tool. 

 

Step 2: The writer is open; confirm that the writer Device is connected to PC 

 

Not connect 

Connect 



 

 

TWR98/99/100 Writer User Manual 

 
 

 

UM-TWR98_99_E  22 Rev 3.2,  2018/02/05 

 

Step 3: Execute Device (Select CHIP)  Note: search function can be used to search 

 
 

Step 4: Select CHIP ok. 
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Step 5: Execute File =>Load File. 

 
 

Step 6: Load the file 
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Step 7: When loading the file, the hardware of the LCD will display as follows 

(Please don't power off or plug out USB cable) 

 
 

Step 8: Click on OK, download is completed 

(If you don't click the “OK” button, plug out USB cable will occur Writer stand lone 

operation error, please re-power the Writer can be restored to normal) 
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Step 9: Start execution (already  loading into hardware) 

 
 

Step 10: After successfully loading the file, the LCD panel on the hardware will display the CHIP 

NAME. 

 
 

Step 11: Select the function on the toolbar (Auto, Blank, Check, Program, Verify). 
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6. LCD Error Messages 

6.1:   PROTECT =>IC data are protected and cannot be read. 

6.2:   BUSY FAIL =>Check if the IC Programming signals are connected to Writer. 

6.3:   B FAIL =>Blank Test fails 

6.4:   P FAIL =>Programming data fails 

6.5:   V FAIL =>Comparing data fails 

6.6:   I FAIL =>4-bit series Enter Programming Mode fails, or 8-bit series ID Programming fails 

6.7:   D FAIL =>Check ID fail 

6.8:   F FAIL =>Programming FUSE or SYSTEM CONFIG fails 

6.9:   NO CHIP =>IC or connection is not connected properly. Please confirm whether IC is put 

properly or the line is connected perfectly. 

6.10: C/E FAIL =>Writer Checksum data comparing error 

6.11: ENTRANCEF =>Check IC entering write mode fail 

6.12: Busy Fail => Busy Fail => Writer wait IC busy time out 

6.13: C Fail => Checksum Data verify fail 
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7. Set-up and Operations for Programming Serial Number 

Step 1: Select “Device” : 

 
 

Step 2: After selecting IC, please enable the “Display Serial Number”, and then click on “OK”. 

 



 

 

TWR98/99/100 Writer User Manual 

 
 

 

UM-TWR98_99_E  28 Rev 3.2,  2018/02/05 

 

Step 3: Enter “Serial Number Set” =>Set up the Serial Number parameters. 

 
 

Step 4:  Set up the S/N Length [Hex] (range: 0x01~0x10) 

Step 5:  Set up the S/N Start Address [Hex]. 

Step 6:  Set up the Start Serial NO [Hex]. 

Step 7:  Set up the S/N Amount [Hex] (the amount of OTP IC programming).  

Step 8:  Set up the S/N Direction [MSB In] 

For Example: Serial Number value=12345678 

Select “Low Byte” to program the IC location: 12 34 56 78 

Select “High Byte” to program the IC location: 78 56 34 12 

Step 9: After finishing set up, click the Load button (load the serial configuration data into Writer, 

please wait for it to complete) 

 
 

Step4 

Step5 

Step6 

Step7 

Step8

8 

Step9 
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Step 10: After setting the “Serial Number Set” setup, click on the “Load” button. 

 
 

Step 11: Execute File ->Load File 
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Step 12: Wait until the files are downloaded OK, click on “ confirm ” button to enter the Serial 

Number Program mode 

 
 

Step 13: Click on “ S/N Program ” button to start programming  

 

Note: After the completion of programming, if programming code + serial number is desired, go back 

to Step 1 and start all over. 
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After the above steps are completed, the user can choose two modes of operation: to connect to PC and 

let PC control the programming process or go offline and programmed by using writer independently. 

1. Operating instruction in using PC to control the programming process: 

a. Click on S/N Program button to start the programming process. 

b. If programming is successful, the count number for “ Start Serial NO, OK, Total ” will be 

incremented by 1 automatically. 

c. If programming is fail, the count number for “ NG, Tota l ” will be incremented by 1 

automatically. 

d. When the S/N Program button is disabled, it means that the programming process for the serial 

number is completed. Reset and reload by entering the “ S/N SET ” window is required. 

e. “ Reset Count ” button will reset the “ OK, NG, Total ” column value to zero. 

f. Attention: Do not press the “ Enter ” key on the writer hardware during programming if PC 

control mode is used. 

 
2. Operating instruction in using writer for programming independently: 

a. The function for the Mode button is to choose whether to display the value for “ Serial Number, 

OK, NG, TOTAL ”. 

a-1: SNH =>Display Serial Number (9~16 bytes) , but when S/N Length is less than 9, this mode 

will not display the number. 

 
 

a-2: SNL =>Display Serial Number (1~8 bytes). 

 
 

a-3: OK =>Display the number of successful programming. 
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a-4: NG =>Display the number of fail programming. 

 
 

a-5: TOTAL =>Display the total number of programming. 

 
 

b. The function for the “ Enter ” key is to execute programming. 

c. If programming is successful, the value of “ Serial Number, OK, TOTAL ” will be incremented 

by 1 automatically. 

d. If programming is fail, the value of “ NG, TOTA L” will be incremented by 1 automatically. 

e. When the “ Enter ” key is disabled, it means that the programming for the serial number is 

completed and the must be reloaded. 

f. Attention: if the power of writer is turned off and on again, the serial number will be reset to the 

initial value. 

  



 

 

TWR98/99/100 Writer User Manual 

 
 

 

UM-TWR98_99_E  33 Rev 3.2,  2018/02/05 

 

8. Programming Operation in EXHV ISP Mode 

Step 1: Select Device 

 
 

Step 2: Select IC and enable “ EXHV ISP Program ”, and then click on “ OK ” 

 
  



 

 

TWR98/99/100 Writer User Manual 

 
 

 

UM-TWR98_99_E  34 Rev 3.2,  2018/02/05 

 

Step 3: The main screen will exhibit “ EXHV ISP Program ” 

 
 

Step 4: Select File ->Load File 
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Step 5：Wait until files are downloaded, click on OK to complete the download 

 

 

Step 6: Downloaded OK 
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9. Programming Operation in ISP Mode 

Step 1: Select Device  

 
 

Step 2: Select IC and enable “ ISP Program ”, and then click on “ OK ” 
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Step 3: The main screen will exhibit “ ISP Program ” 

 
 

Step 4: Select File ->Load File 
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Step 5: Wait until files are downloaded, click on OK to complete the download 

 
 

Step 6: Downloaded OK 
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10. Programming Operation in Whole Chip Erase Mode 

Step 1: Select Device  

 
 

 

Step 2: Select IC and enable “ Whole Chip Erase ”, and then click on “ OK ” 
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Step 3: The main screen will exhibit “Whole Chip Erase” 

 

 

Step 4: Select File ->Load File 
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Step 5: Wait until files are downloaded, click on OK to complete the download 

 

 

Step 6: Downloaded OK 
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11. Programming Guide for Mass Production Mode 

This function contains only Auto mode, which records OK and NG counts, and checksum display, there 

are no other functions, so it is recommended to be used in mass production. 

Step 1: Select Device 

 
 

Step 2: Select IC type and enable the “ Mass Production Mode ”, and then click on “ OK ” 
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Step 3: The main screen will show “ Mass Production Mode ” and Enable Auto function  

 
 

Step 4: Execute File ->Load File 
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Step 5: Wait until files are downloaded, click on OK to complete the download 

 
 

Step 6: Downloaded OK 
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Step 7: Hardware Display and Operate: 

a. Display CHIP NAME (Hold 2 sec Display) 

 
 

b. Display Auto Mode: (Mode button: click once will change OK and NG Display) 

1. Display Checksum 

2. Display the counting number that the programming procedure is successful 

3. Display the counting number that the programming procedure is not successful 

 
 

 
 

c. Display Software version and Firmware version (Press the Mode button more than 3 

seconds continuously to get the information) 

 
 

d. Enter button: press enter to execute 

  

Checksum 

OK 數量 

NG 數量 
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12. Production Limit Mode Writer Operation  

This function contains only Auto mode, which records OK and NG counts, and checksum display, there 

are no other functions, so it is recommended to be used in mass production. 

Step 1: Select Device  

 

 

Step 2: Select IC and enable the Production Limit Mode to set the writer counts (1~99999999) , then 

press OK. 
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Step 3: Main window will show “ Production Limit Mode ” and enable “ Auto ” function 

 
 

Step 4: Select File ->Load File 
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Step 5: Wait until files are downloaded, click on OK to complete the download 

 
 

Step 6: Download OK 
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Step 7: Hardware display and operation: 

a. Display CHIP NAME (holds for 2 secs display) 

 
 

b. Display Limit mode: (hardware mode button can only switch to OK and NG display) 

1. Checksum 

2. Write OK count 

3. Write NG count 

 
 

 
 

c. Display Software version and Firmware version (Press the Mode button more than 3 

seconds continuously to operate this function) 

 
 

d. Enter button: press enter to execute 

e. When OK count reaches the writing limit setting, writer will not continue to execute 

  

Checksum 

OK 數量 

NG 數量 



 

 

TWR98/99/100 Writer User Manual 

 
 

 

UM-TWR98_99_E  50 Rev 3.2,  2018/02/05 

 

13. Manually Update Firmware Function Guide 

Step 1: Execute Operation =>Update F/W 

 
 

Step 2: Select the file to Update. 
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Step 3: Start execution (start loading into hardware), click on OK to complete the set 

 
 

Step 4: During the Updating Firmware period, the LCD will display UPDATE_FW WAIT. 

 
 

Step 5: After successfully updating Firmware, the LCD will display the CHIP NAME. 
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14. Compare File Function Operation 

Display writer register data, “ IC Name ”, “ Download File Time ”, and “ Compare File Result ”. 

Step 1: Select Operation ->Compare File 

 

 

Step 2: Download File information window shows up 
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Step 3: Press “ Compare File ” button, select the file to be compared, then press “ Open ” button. 

 
 

Step 4: Wait for compare result, OK/Fail 
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15. Set Protect Function Operation 

Step 1: Select Operation ->Set Protect 

 
 

Step 2: Option Select 1 window shows up 
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Step 3: Select Unprotect or Protect, then press “ OK ” button, wait for the setting completes 
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16. Read Chip Info Function Operation 

Note: It does not support Mass Production and Production Limit mode. 

Read Target IC info, “ system config ”, “ checksum ”, “ ID ”. 

Step 1: Select Operation ->Read Chip Info 

 
 

Step 2: Read chip information window shows up 
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Step 3: Press “ Read ” button, start reading, wait for completed 
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17. Read Hardware ID Operation 

 
Step 1: Select Help ->Read Hardware ID 

 
 

Step 2: Click on OK, read writer hardware ID successfully 
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18. Read License ID Operation 

 
Step 1: Select Help ->Read License ID 

 

 
Step 2: Read Writer License ID successfully (details, please refer to License User Manual) 
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19. Reset Firmware Operation 

 
Step 1: Select Help ->Reset Writer F/W ->TWR98 or TWR99 

 

 
Step 2: Click on OK, reset firmware successfully 
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20. Writer Simple Test Operation 

 
Step 1: Select Help ->Writer Simple Test (Please remove the program port cable and chip first) 

 

 
Step 2: Click on OK, writer simple test complete 
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21. Software Plugin Operation 

 
Step 1: Select Help ->Update Chip 

 

 
Step 2: Select plugin file.zip 
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Step 3: Click on OK, software update successfully 
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